MZL’s Border
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 835 Accepted Submission(s): 268
Problem Description
As is known to all, MZL is an extraordinarily lovely girl. One day, MZL was playing with her favorite data structure, strings.
MZL is really like
Fibonacci Sequence, so she defines
Fibonacci Strings in the similar way. The definition of
Fibonacci Strings is given below.
1)
fib1=b
2)
fib2=a
3)
fibi=fibi−1fibi−2, i>2
For instance,
fib3=ab, fib4=aba, fib5=abaab.
Assume that a string
s whose length is
n is
s1s2s3…sn. Then
sisi+1si+2si+3…sj is called as a substring of
s, which is written as
s[i:j].
Assume that
i
Now you are given 2 numbers
n and
m. MZL wonders what
LBorderm of
fibn is. For the number can be very big, you should just output the number modulo
258280327(=2×317+1).
Note that
1≤T≤100, 1≤n≤103, 1≤m≤|fibn|.
Input
T, which means the number of test cases.
Then for the following
T lines, each has two positive integers
n and
m, whose meanings are described in the description.
Output
T lines. Each has one number, meaning
fibn’s
LBorderm modulo
258280327(=2×317+1).
Sample Input
2
4 3
5 5
Sample Output
1
2
Source
2015 Multi-University Training Contest 5
点击打开链接
import java.util.Scanner;
import java.math.BigInteger;
public class Main{
public static void main(String[] args){
Scanner sc = new Scanner(System.in);
int N = sc.nextInt();
BigInteger[] a=new BigInteger[1055];
BigInteger[] b=new BigInteger[1055];
a[1]=BigInteger.valueOf(1);
a[2]=BigInteger.valueOf(2);
for(int i=3;i0)
{
N--;
int n=sc.nextInt();
BigInteger m = sc.nextBigInteger();
for(int i=1;i=0 )
{
System.out.println((m.subtract(a[i-1])).mod(BigInteger.valueOf(258280327)));
break;
}
}
}
}
}
服务器托管,北京服务器托管,服务器租用 http://www.fwqtg.net
机房租用,北京机房租用,IDC机房托管, http://www.e1idc.net