|
Max SumTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Problem Description
Input
Output For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input 2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output Case 1: 14 1 4 Case 2: 7 1 6
Author Ignatius.L |
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
int t, i;
Scanner in = new Scanner(System.in);
t = in.nextInt();
for (i = 0; i max) {
l = tempStep;
r = i + 1;
max = sum;
}
if (sum
服务器托管,北京服务器托管,服务器租用 http://www.fwqtg.net
机房租用,北京机房租用,IDC机房托管, http://www.fwqtg.net
相关推荐: 精细运营、数据赋能、生态联动…银行大零售数字化转型攻略
当前我国银行业的内外部环境正在发生深刻的变化,数字化转型已经成为行业的普遍共识。尤其在银行大零售数字化转型的过程中,各家银行差异性较大,虽然都开始突破传统零售模式,但仍面临一些共性的挑战,比如缺乏科学的顶层规划、应用层面的数字化手段亟待提升、数据与IT基础设计…